CATI interviewers on the Euro SaaS experiencing issues logging in

Incident Report for Forsta

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 16:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results. If interviewers continue to experience problems with logging in please ask them to try fully closing their browser application before re-attempting the log in process.
Posted Aug 18, 2025 - 15:02 UTC

Investigating

We are currently investigating the issue and will post updates as soon as we have more information.
Posted Aug 18, 2025 - 14:36 UTC
This incident affected: Forsta Plus EURO (CATI).