Some end users have issues accessing Studio Reports on Euro site

Incident Report for Forsta

Update

We are continuing to work on a fix for this issue.
Posted Apr 20, 2026 - 17:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 20, 2026 - 13:26 UTC

Investigating

We are currently investigating this issue.
Posted Apr 20, 2026 - 11:39 UTC
This incident affects: Forsta Plus EURO (Studio viewers).