Forsta Plus Euro SaaS site issues - Launch survey, access to site

Incident Report for Forsta

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 16:10 UTC

Monitoring

The Forsta Cloud Operations team has recycled several backend services that were in a degraded state. As a result, tasks are now completing successfully, and previously reported errors in Survey Designer should be resolved.
We are continuing to monitor the site closely over the next few hours to ensure stability and optimal performance.
Posted Oct 10, 2025 - 15:50 UTC

Investigating

We are currently investigating issues with the Forsta Plus Euro SaaS site. Monitoring is showing errors with Launch survey tasks, accessing the home page. Forsta Cloud Operations are investigating, and we will provide an update within 30 minutes.
Posted Oct 10, 2025 - 15:25 UTC
This incident affected: Forsta Plus EURO (Studio designers, Task system, Survey designer).