Forsta Plus: We are currently investigating an issue with logging into Authoring for US site.

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted Feb 11, 2026 - 09:24 UTC

Investigating

Updated status will be provided within 30 minutes.
Posted Feb 11, 2026 - 09:13 UTC
This incident affected: Forsta Plus US (Survey designer).