The situation remains stable on most sites. We are now seeing this issue on the AUS site, but that should resolve with the next deployment, which should be within the next few hours. I will provide an update within four hours.
Posted May 21, 2026 - 12:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Initial results seem promising. Will continue to monitor throughout the rest of the day and tomorrow's deployment. A few customers may continue to see errors throughout the day, but these should clear up by tomorrow. Will provide an update tomorrow morning.
Posted May 20, 2026 - 18:00 UTC
Investigating
Affected users will see an error in all Studio widgets using Action management data if they try to filter by reporting period. If they disable the filter, affected users will see delays in case data updating for these widgets.
Note that case creation is not affected at this time.
We are actively investigating.
Posted May 20, 2026 - 12:18 UTC
This incident affects: Forsta Plus EU (Studio viewers, Studio designers), Forsta Plus AUS (Studio viewers, Studio designers), Forsta Plus US2 (Studio viewers, Studio designers), and Press Ganey HX Platform (Foundations).