Forsta Plus: We are currently investigating an issue with Studio AI Summary Widget for UK and US Azure Multi Tenant Sites

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted Jul 23, 2026 - 17:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 23, 2026 - 16:10 UTC

Investigating

Updated status will be provided within 1 hours.
Posted Jul 23, 2026 - 15:22 UTC
This incident affected: Forsta Plus US2 (Studio viewers).