Forsta Plus: We are currently investigating an issue with Reminder Emails in Action Management for all environments.

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted Mar 17, 2026 - 18:22 UTC

Monitoring

A fix has been implemented. We will monitor the results to confirm whether or not this has resolved the issue. We can provide an update by the end of the day.
Posted Mar 17, 2026 - 13:11 UTC

Identified

A potential fix is being implemented. We will provide an update tomorrow morning.
Posted Mar 16, 2026 - 20:31 UTC

Investigating

Pre-overdue, overdue, and post-overdue email notifications are not being sent in Action Management.  We are currently investigating, and should have an update by the end of the day Eastern Time.
Posted Mar 16, 2026 - 12:57 UTC
This incident affected: Forsta Plus KSA (Studio viewers), Forsta Plus CA (Studio viewers), Forsta Plus EU (Studio viewers), Forsta Plus AUS (Studio viewers), Forsta Plus EURO (Studio viewers), Forsta Plus US (Studio viewers), Forsta Plus DE (Studio viewers), Forsta Plus UAE (Studio viewers), Forsta Plus AU (Studio viewers), Forsta Plus US2 (Studio viewers), and Press Ganey HX Platform (Foundations).