HX Platform: We are currently investigating an issue with degraded system performance for the Press Ganey HX Platform.
Incident Report for Forsta
Resolved
This issue has been resolved.
Posted Jul 09, 2024 - 21:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2024 - 20:54 UTC
Update
Continuing to investigate. Updated status will be provided within 30mins.
Posted Jul 09, 2024 - 20:24 UTC
Investigating
We are seeing sporadic slowness for interviewing and designer usage on the platform. An updated status will be provided within 30mins.
Posted Jul 09, 2024 - 19:55 UTC
This incident affected: Press Ganey HX Platform (CAWI, Studio viewers, Task system, Survey designer, Hierarchy management).