Forsta Plus: We are currently investigating an issue with CATI interviewing for the Euro site.

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted May 19, 2025 - 13:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2025 - 13:38 UTC

Investigating

Updated status will be provided within 30 minutes.
Posted May 19, 2025 - 13:32 UTC
This incident affected: Forsta Plus EURO (CATI).