Issues with Survey Designer on Press Ganey HX Platform
Incident Report for Forsta
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 20:21 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 15, 2025 - 20:21 UTC
Monitoring
The issue has been identified and our teams are monitoring the site currently for any additional issues.
Posted Jan 15, 2025 - 19:51 UTC
Update
The Forsta Cloud Operations team is currently investigating the issues on the Press Ganey HX Platform. More details to follow in 15 minutes.
Posted Jan 15, 2025 - 19:39 UTC
Investigating
Issues with Survey Designer on Press Ganey HX Platform - Forsta Support is investigating
Posted Jan 15, 2025 - 19:10 UTC
This incident affected: Press Ganey HX Platform (Foundations).