Forsta Plus: We are currently investigating an issue with retrieving data for Studio on EURO and EU.

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted Feb 17, 2025 - 11:18 UTC

Update

We are continuing to investigate this issue.
Posted Feb 17, 2025 - 11:17 UTC

Investigating

Updated status will be provided within 60 minutes.
Posted Feb 17, 2025 - 11:16 UTC
This incident affected: Forsta Plus EURO (Studio viewers, Survey designer) and Forsta Plus EU (Studio designers, Survey designer).