A fix is currently being implemented, and site stability has already improved for many users. We continue to monitor the environment closely and are actively working to fully resolve the remaining issues. Some customers may still experience intermittent slowness or degraded performance.
We will provide another update as more information becomes available.
Posted Jun 10, 2026 - 12:37 UTC
Investigating
We are currently investigating stability and performance issues affecting our Euro SaaS environment.
Customers may experience slowness, intermittent errors, or degraded availability across multiple areas of the platform, including survey respondent access, professional user actions, and CATI operations.
Our teams are actively working to identify the root cause and restore normal service as quickly as possible. We will provide further updates as more information becomes available.
Posted Jun 10, 2026 - 10:38 UTC
This incident affects: Forsta Plus EURO (CAPI, CATI, CAWI, Reportal viewers, Studio viewers, Reportal designers, Studio designers, Task system, Survey designer, Text analytics, Public APIs, Hierarchy management, CRM Connector).