Forsta Plus: We are currently investigating an issue with Survey Launches and Data Exports for EU site.

Incident Report for Forsta

Resolved

This issue has now been resolved.
Posted Apr 13, 2026 - 12:38 UTC

Update

We are still looking into the issue regarding survey launches. Updated status will be provided within 60 minutes
Posted Apr 13, 2026 - 11:52 UTC

Update

We are continuing to investigate the issue with survey launches. Updated status will be provided within 60 minutes.
Posted Apr 13, 2026 - 10:57 UTC

Update

The issue with exports should now be resolved. We are still looking into the issue regarding survey launches. Updated status will be provided within 60 minutes
Posted Apr 13, 2026 - 09:50 UTC

Update

We are continuing to investigate this issue. Updated status will be provided within 60 minutes.
Posted Apr 13, 2026 - 09:33 UTC

Investigating

Updated status will be provided within 60 minutes.
Posted Apr 13, 2026 - 08:41 UTC
This incident affected: Forsta Plus EU (Task system).