Forsta Plus: We are currently investigating an issue with slowness in CATI Interviewing for Euro site.

Incident Report for Forsta

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 20:23 UTC

Update

After a brief incident between 6:45 PM and 6:55 PM UK time, we will continue actively monitoring the site throughout the evening to watch for any additional disruptions.
Posted Nov 12, 2025 - 19:33 UTC

Monitoring

The Forsta Cloud Operations team has identified a backend process that was in a bad state and have restarted that particular part of the application. We're seeing indications that this has resolved the issues clients were experiencing with CATI slowness. The Forsta Team will continue to monitor the site for any other unusual performance indicators.
Posted Nov 12, 2025 - 18:02 UTC

Update

The Forsta Cloud Operations team are currently troubleshooting an issue on the Euro SaaS site. The investigation is ongoing, and senior members of their organization have been involved. More details to follow within 30 minutes.
Posted Nov 12, 2025 - 17:53 UTC

Investigating

Updated status will be provided within 30 minuttes.
Posted Nov 12, 2025 - 17:13 UTC
This incident affected: Forsta Plus EURO (CATI).