We are currently working with Rackspace to resolve stability issues with email delivery tasks on the US site

Incident Report for Forsta

Resolved

The PowerMTA instance was instable due to disk related problem. Emailing send outs were impacted with delays as a result. Rackspace has now corrected the disk problem and the issue should be stable again.
Posted Mar 11, 2026 - 14:13 UTC

Investigating

We are currently investigating this issue.
Posted Mar 11, 2026 - 11:04 UTC
This incident affected: Forsta Plus US (Task system).