Forsta Plus: We have identified an issue with Action management case generation on US SaaS site

Incident Report for Forsta

Update

Case generation is catching up, but it may take until tomorrow morning before all missed cases are generated.

It is recommended that triggers on the US be set to a case creation window of 3 days or higher to make sure that no cases are missed.
Posted May 21, 2026 - 19:46 UTC

Monitoring

We have rolled back the affected component. Case creation appears to be working now. We will monitor for the rest of the day.
Posted May 21, 2026 - 17:37 UTC

Investigating

Cases are not being generated on the US site. We are investigating. We are looking into performing a rollback. Will provide an update ASAP.
Posted May 21, 2026 - 16:46 UTC
This incident affects: Forsta Plus US (Studio viewers, Studio designers).