Resolved – CATI Performance Issues (US SaaS) The CATI performance issue affecting the US SaaS environment has been fully resolved. After working with our cloud operations team and recycling affected backend services, system performance has returned to normal and remains stable.
Thank you for your patience while we addressed this incident. If you experience any additional issues, please reach out to our support team.
Posted Nov 20, 2025 - 02:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 02:00 UTC
Identified
Our team has been actively working with our core operations group to address the CATI performance issues impacting the US SaaS environment. Several backend services have been recycled, and we are now observing improved system performance.
We will continue to closely monitor the environment to ensure stability. If you continue to experience any significant issues, please contact support so we can investigate further.
Next update will be provided as needed or when the issue is fully resolved.
Posted Nov 20, 2025 - 01:45 UTC
Investigating
We’re currently experiencing issues with CATI on the US SaaS site. Our team is actively investigating and we’ll provide an update as soon as we have more information. Thanks for your patience.