Issue with access to Professional Authoring on the US SaaS environment

Incident Report for Forsta

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 14:09 UTC

Monitoring

This is resolved, there was a routing issue on the networking side. If you are having further issues accessing Professional Authoring, please try and clear your cache.
Posted Mar 18, 2025 - 14:03 UTC

Investigating

We are currently investigating an issue with access to Professional Authoring on the US SaaS environment.
Posted Mar 18, 2025 - 12:33 UTC
This incident affected: Forsta Plus US (Survey designer).