Forsta Plus: We are currently investigating an issue with the task system for Euro.

Incident Report for Forsta

Update

We are continuing to investigate this issue. Updated status will be provided within 60 minutes.
Posted Apr 29, 2026 - 11:09 UTC

Investigating

Updated status will be provided within 60 minutes
Posted Apr 29, 2026 - 10:16 UTC
This incident affects: Forsta Plus EURO (Task system).