Issue with reduced email deliverability on the AUS SaaS environment

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted Mar 11, 2025 - 09:28 UTC

Monitoring

We are pleased to announce that the IP block on our Australia SaaS site has been de-listed by the Third Party Anti-Spam Organization. We are asking our clients to please be vigilant in following our guidelines with regards to sending emails from our site. For reference here is our Acceptable Usage Policies wording regarding emailing standards that we request our clients to use when sending emails https://legal.forsta.com/legal/forsta-plus-aup/

Tips on best practices for Email Deliverability : https://forstaplus.zendesk.com/hc/en-us/articles/25509936188827-Email-Deliverability-Best-Practices-for-Successful-Inbox-Placement

If you would like more control over emailing from the site, we offer a few solutions for Dedicated emailing (IP), more information here : https://forstaplus.zendesk.com/hc/en-us/articles/25508748725531-Emailing-at-Forsta


As a further piece of information, you may have seen a recent announcement regarding the migration of our Australia SaaS site from a dedicated Datacenter host to a Microsoft Azure Cloud Platform (The Forsta Plus AUS Platform will be migrating to Azure Cloud on the weekend of 5-6 April 2025). This migration will give some extra tools for managing email send outs that we can use to further manage emailing from the site. We still would ask that clients maintain best practices with sending emails from our Shared Platform to help with maintaining our sites reputation.
Posted Mar 06, 2025 - 16:10 UTC

Update

Update and Summary of current situation : A Third party Anti-Spam organization has added the Forsta Plus Australia SaaS site's email IP to their block list due to some emails from the site being caught in Spam Traps.

The Forsta Plus SaaS site emailing is shared by all clients (except those using a Dedicated IP Address) using the site and we have in our Acceptable Usage Policies wording regarding emailing standards that we request our clients to use when sending emails https://legal.forsta.com/legal/forsta-plus-aup/

Due to the recent flagging of our IP Address, the third party Anti-Spam Organization has been focusing more attention on emails sent from this site.

We'd like to request that all clients review our Acceptable Usage Policy above, as well as a page on our help center that we've updated with tips on best practices for Email Deliverability : https://forstaplus.zendesk.com/hc/en-us/articles/25509936188827-Email-Deliverability-Best-Practices-for-Successful-Inbox-Placement

If you would like more control over emailing from the site, we offer a few solutions for Dedicated emailing (IP), more information here : https://forstaplus.zendesk.com/hc/en-us/articles/25508748725531-Emailing-at-Forsta

We will be reaching out to additional clients whose emails have been flagged by the Anti-Spam organization to help clear this blockage. Additional conversations continue with the Third Party organization to help address this scenario as soon as possible.
Posted Mar 05, 2025 - 18:02 UTC

Investigating

We are currently investigating an issue with reduced email deliverability on the AUS SaaS environment
Posted Feb 28, 2025 - 08:51 UTC
This incident affected: Forsta Plus AUS (CAWI).