The issue affecting CAWI survey links and CATI telephone interviewing activities has been fully resolved.
Fixes were successfully deployed across all affected sites, and our teams have completed an extended monitoring period confirming that services are operating normally and platform stability has been restored.
We appreciate your patience and understanding throughout this incident. If you experience any further issues, please contact Support for assistance.
Posted Aug 18, 2026 - 21:12 UTC
Monitoring
We have successfully deployed fixes across all affected environments and are now in the monitoring phase.
Service functionality for CAWI survey links and CATI telephone interviewing activities has been restored, and our teams are actively monitoring the platform to ensure continued stability and performance.
We will continue to observe the environment closely and will provide a final update once we have confirmed the issue is fully resolved.
Thank you for your patience throughout this incident.
Posted Aug 18, 2026 - 20:03 UTC
Identified
We have addressed the underlying issue and are in the process of deploying fixes to all affected sites. Service restoration is progressing, and we are closely monitoring the environment to ensure stability.
We will provide another update once deployment has been completed across all sites.
Posted Aug 18, 2026 - 19:51 UTC
Update
We are currently investigating an issue affecting multiple environments that may impact: Access to CAWI survey links / CATI telephone interviewing activities
The issue has been escalated and is receiving immediate attention from our technical teams. We are actively investigating and working to restore full functionality as quickly as possible.
We will share our next update as soon as we have more information regarding the cause and remediation efforts.
Thank you for your patience and continued partnership.
Posted Aug 18, 2026 - 19:31 UTC
Investigating
We are currently investigating an issue affecting the MT-EU environment where users may experience problems accessing CAWI survey links and conducting CATI telephone interviewing activities.
Our teams are actively working to identify the root cause and restore normal functionality as quickly as possible. We will provide additional updates as more information becomes available.
Posted Aug 18, 2026 - 18:00 UTC
This incident affected: Forsta Plus EURO (CATI, CAWI), Forsta Plus AUS (CATI, CAWI), Forsta Plus EU (CATI, CAWI), Forsta Plus CA (CATI, CAWI), Forsta Plus AU (CATI, CAWI), Forsta Plus US2 (CATI, CAWI), and Press Ganey HX Platform (Foundations, iRound, Patient Experience (PGFusion), Employee Experience, Consumer Experience).