Forsta Plus: We are currently investigating an issue with users logging into the EURO SaaS Site
Incident Report for Forsta
Resolved
This issue has been resolved.
Posted Jun 06, 2024 - 09:17 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 06, 2024 - 08:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2024 - 08:23 UTC
Update
Updated status will be provided within 30mins.
Posted Jun 06, 2024 - 07:52 UTC
Investigating
Users can still log into Professional Authoring. Web interviewing is not affected.
Updated status will be provided within 30mins.
Posted Jun 06, 2024 - 07:21 UTC
This incident affected: Forsta Plus EURO (CATI, Studio designers, Survey designer).