Forsta Plus/HX Platform US SaaS site - CATI interviewing slowness

Incident Report for Forsta

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 21:33 UTC

Monitoring

The Backend process that was causing issues with CATI interviewing has been restarted and the Forsta Cloud Operations team is monitoring for further instances.
Posted Jul 31, 2025 - 21:24 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2025 - 21:23 UTC

Investigating

We are currently troubleshooting some backend processes that are affecting CATI interviewing on the US SaaS site. This is being treated with a high priority, and we'll be providing an update within 30 minutes.
Posted Jul 31, 2025 - 21:17 UTC
This incident affected: Forsta Plus US (CATI).