Forsta Plus: We are currently investigating an issue with Professional User access for US SaaS.
Incident Report for Forsta
Resolved
This issue has been resolved.
Posted Aug 05, 2024 - 14:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2024 - 14:25 UTC
Update
We are continuing to investigate this issue.
Posted Aug 05, 2024 - 14:22 UTC
Investigating
We are seeing sporadic issues with users not being able to log into the US SaaS site.
Updated status will be provided within 30mins.
Posted Aug 05, 2024 - 14:18 UTC
This incident affected: Forsta Plus US (Studio designers, Task system, Survey designer).