Forsta Plus: We are currently investigating an issue with legacy Action Management on most sites.

Incident Report for Forsta

Identified

We have applied a fix that appears to have resolved this on all sites except the US site. The US environment uses a different architecture.

The issue should be resolved before 8 AM Eastern Time tomorrow. At that time I can provide an update.
Posted Aug 18, 2026 - 18:51 UTC

Investigating

The classic Action Management client is not loading. Cases continue to be created, and New Action Management (in the hub and Studio) is unaffected.

We will have an update in a few hours.
Posted Aug 18, 2026 - 12:38 UTC
This incident affects: Forsta Plus CA (Studio viewers, Studio designers), Forsta Plus EU (Studio viewers, Studio designers), Forsta Plus EURO (Studio viewers, Studio designers), and Forsta Plus US (Studio viewers, Studio designers).