KSA site - Issues with Services on KSA site after maintenance earlier today

Incident Report for Forsta

Resolved

The issues impacting our KSA site have been resolved, and all core systems are operational. Our engineering team will continue monitoring performance throughout the evening to ensure ongoing stability as traffic normalizes. We appreciate your patience.
Posted Sep 10, 2026 - 18:14 UTC

Monitoring

Resolution: The service issues impacting our KSA site have been fully resolved, and all systems are operating normally.

What Happened: Following earlier routine maintenance, several background server nodes experienced a connectivity issue with our network storage services, leading to temporary access errors and site instability. Our engineering team isolated the affected servers, safely redirected traffic to healthy systems, and re-established normal storage connections.

Next Steps: The site is fully functional, and we are continuously monitoring performance to ensure stability. Our team is conducting a thorough post-incident analysis alongside our infrastructure partners to determine the root cause and prevent future recurrence. We sincerely appreciate your patience.
Posted Sep 10, 2026 - 11:51 UTC

Investigating

Investigating Service Degradation – KSA Region

We are currently investigating service issues impacting our KSA site following scheduled maintenance performed earlier today. Our engineering team is actively working to restore full functionality. We apologize for the inconvenience and will provide further updates as they become available.
Posted Sep 09, 2026 - 21:07 UTC
This incident affected: Forsta Plus KSA (CAWI, Task system, Survey designer).