Forsta Plus US SaaS - Slowness in CATI Interviewing

Incident Report for Forsta

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 20:46 UTC

Monitoring

The Forsta Cloud Operations team has identified the issue, and a fix has been applied to the servers. We're continuing to monitor for further instances of errors.
Posted Jul 24, 2025 - 20:28 UTC

Investigating

Forsta Plus US SaaS - Slowness in CATI Interviewing - We are currently investigating reports of slowness in CATI interviewing on the US SaaS site. Forsta Cloud Operations team are engaged and actively troubleshooting with support.
Posted Jul 24, 2025 - 19:35 UTC
This incident affected: Forsta Plus US (CATI).