Forsta Plus: We have identified an issue with the display of Action Management case data for several clients across all environments.

Incident Report for Forsta

Update

We are continuing to work on a fix for this issue. We should have another update by the end of the day.
Posted Mar 24, 2026 - 17:17 UTC

Identified

Some reporting views show delayed Action Management case data for programs, as well as errors when using certain filters. Recent case activity starting yesterday may not yet appear in these views, and case counts may not reflect the latest updates.

Please note that no case data has been lost, and Action Management case creation and assignment continues to function normally.

We are working on a potential solution we hope to deploy tomorrow. We will be able to provide an update in the next few hours.
Posted Mar 24, 2026 - 13:46 UTC
This incident affects: Forsta Plus KSA (Studio viewers), Forsta Plus CA (Studio viewers), Forsta Plus EU (Studio viewers), Forsta Plus AUS (Studio viewers), Forsta Plus EURO (Studio viewers), Forsta Plus US (Studio viewers), Forsta Plus DE (Studio viewers), Forsta Plus UAE (Studio viewers), Forsta Plus AU (Studio viewers), Forsta Plus US2 (Studio viewers), and Press Ganey HX Platform (Foundations).