Forsta Plus: CRM Connector down on Euro

Incident Report for Forsta

Resolved

This issue has been resolved.
Posted Sep 22, 2025 - 17:36 UTC

Update

Still investigating the issue. Updated status will be provided in 60 minutes.
Posted Sep 22, 2025 - 16:59 UTC

Update

Still investigating the issue. Updated status will be provided within 60 minutes
Posted Sep 22, 2025 - 15:29 UTC

Update

Still investigating the issue. Updated status will be provided within 30 minutes
Posted Sep 22, 2025 - 14:50 UTC

Investigating

We are investigating the issue. Updated status will be provided within 30 minutes
Posted Sep 22, 2025 - 14:24 UTC
This incident affected: Forsta Plus EURO (CRM Connector).