Forsta Plus: Some Studio users are unable to publish reports on MT-EU site

Incident Report for Forsta

Update

We are continuing to investigate this issue.
Posted Sep 17, 2026 - 08:13 UTC

Investigating

Updated status will be provided within 2 hours.
Posted Sep 17, 2026 - 08:07 UTC
This incident affects: Forsta Plus EU (Studio designers).