Forsta Plus: We are currently investigating an issue with Survey Desinger for DE site.

Incident Report for Forsta

Update

The Ops and R&D teams are continuing to look into this issue. An update will be posted when we have more news on this issue.
Posted May 18, 2026 - 15:16 UTC

Update

We are continuing to look into this issue. Updated status will be provided within 60 minutes
Posted May 18, 2026 - 14:15 UTC

Update

We are continuing to look into this issue. Updated status will be provided within 60 minutes
Posted May 18, 2026 - 13:15 UTC

Update

We are continuing to look into this issue. Updated status will be provided within 60 minutes
Posted May 18, 2026 - 12:15 UTC

Investigating

Updated status will be provided within 60 minutes.
Posted May 18, 2026 - 11:15 UTC
This incident affects: Forsta Plus DE (Survey designer).